Tracker ID Sixty Humminbird no red dot/lamp showing depth

Nitro & Tracker Owners

Help Support Nitro & Tracker Owners:

bernie botzet

New Member
Joined
May 18, 2010
Messages
3
Reaction score
0
I have a Tracker ID Sixty Humminbird depth finder (in dash/console model) and when I turn it on it spins around like it is trying to read the depth but no red dot/lamp shows up on the round display to show me the depth? It appears to be working but no red dot/lamp shows the depth? Any idea what is going on? The depth finder is 15 years old so it may just be worn out? Any help/suggestions is appreciated. THANKS!
 

Humminbird Greg

Well-Known Member
Joined
May 30, 2002
Messages
791
Reaction score
3
Location
Eufaula, Alabama, U.S.A.
BIG FINS,

When I used to work on these indash flashers in the Service Department the reasons for a no light condition like yours were varied. Many times though it was as simple as the neon bulb had burnt out or was broken. It could also be the power transformer, something in the transmitter or even something in the receiver of the unit. No way to tell until you dig into the unit and start looking at what voltages and signals were there. We no longer service these units but if you feel lucky and can solder you can call the Humminbird Customer Resource Center folks and see of you can still get neon bulb to try in your indash flasher. I think that I still have some directions somewhere on how to change one of these if you want to try.





Greg Walters at Humminbird

 

bernie botzet

New Member
Joined
May 18, 2010
Messages
3
Reaction score
0
Hi,

I called Humminbird customer service and they don't have any parts for this old of a unit-not even a neon bulb. If you have the directions, I would like to get a copy of them. I am going to try and find an old unit like mine off of craigslist, etc..
 

Latest posts

Top