1. Welcome to Nitro & Tracker Owners! Join today, registration is easy!

    You can register using your Google, Facebook, or Twitter account, just click here.

Loss Of Rpm At Full Throttle

Thread in 'Motors & Props' started by KCJ, Jul 15, 2017.

  1. KCJ

    KCJ New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Jul 15, 2017
    Location:
    Lawton, ok
    Mercury pro xs 250, 2013 model. Runs 5600 rpm at full throttle. Motor will drop 3 to 4 hundred rpms then pick back up. Ran 5800 rpm before with no drop. What can cause this problem???
     
  2. firedog978

    firedog978 Well-Known Member

    Messages:
    324
    Likes Received:
    5
    Joined:
    Apr 29, 2008
    Location:
    Cincinnati, Ohio
    The most likely reason for what you're describing is the in-line bulb of the fuel line.
    Those bulbs are notorious for breaking down and losing suction. Especially, at full throttle.
    They're in-expensive and simple to replace. Try that and I think your problem will be solved.
     
  3. KCJ

    KCJ New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Jul 15, 2017
    Location:
    Lawton, ok
    Thanks. Changed out the bulb but now will not pump up tight. Started fine and idles with no issues. I will take it to the lake in the morning. I will let you know how it works.

    On the lake now worse than before. Down another 200 rpms. When you stop and fish will not hold pressure. Requires you re-pump the bulb. All connections are tight.
     
  4. iburypaul

    iburypaul New Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    Jul 24, 2017
    Location:
    Texas
    I've got the same issues, interested in responses
     
Loading...

Share This Page