Hello all

Nitro Owners Forum

Help Support Nitro Owners Forum:

Keith Young

New Member
Joined
Oct 25, 2022
Messages
2
Reaction score
1
Location
Pennsylvania
I'm new to the Nitro family I just purchased a 1998 Nitro 912 savage four days ago it was garage kept for the last 10 years never ran and I picked it up this past Saturday ran it all day Sunday no problem's took it out Monday afternoon unloaded off the trailer went about a mile down the lake fished for about three hours went to take off back to the dock and it ran fine for thirty seconds then a alarm came on and it wouldn't let me go over idle

IMG_6937.jpg
so any input would be great thank you
 

NitroAdmin

Administrator
Staff member
Administrator
Joined
Jun 14, 2020
Messages
230
Reaction score
23
Welcome to the forum, Keith. Hope it's just minor. By chance can you share a pic of your boat?
 

Bobsizz

NTO Supporter
Supporting Member
Joined
Oct 1, 2022
Messages
19
Reaction score
5
Location
Arizona
I'm new to the Nitro family I just purchased a 1998 Nitro 912 savage four days ago it was garage kept for the last 10 years never ran and I picked it up this past Saturday ran it all day Sunday no problem's took it out Monday afternoon unloaded off the trailer went about a mile down the lake fished for about three hours went to take off back to the dock and it ran fine for thirty seconds then a alarm came on and it wouldn't let me go over idle

View attachment 2652 so any input would be great thank you
I think thats the engine overheat light on (I could be wrong about that) but if I am right I would check that the cooling system is working properly. You could have a bad water pump, clogged lines, there could be numerous things wrong. I know I'm not much help. Good luck to you and let us know what you find out.
 
Joined
Dec 8, 2021
Messages
180
Reaction score
52
Location
SOUTH
Nice boat! Welcome to the group!
If that motor has sat for 10 years and now you are over heating it, my first guess would be water pump like Bobsizz suggested. The impeller is probably dry rotted and broke apart. If you can wrench and are willing to try it, I would search YouTube by your motor's particular info (year, horse power, optimal etc.) and impeller/ waterpump. Someone has posted a video on how to change that out.
 
Top