Quantcast

Electrical Problem

Nitro & Tracker Owners

Help Support Nitro & Tracker Owners:

Bill Masterson

New Member
Joined
Mar 27, 2020
Messages
2
Reaction score
1
Location
Grove,Ok
Good afternoon, I am brand new to this forum but at a loss as to what to do. I bought my dream boat back in Nov of 2018 (Nitro Z21 2018). It was stolen in the spring of 2019 and when it was found two days later it was stripped. I have had all the components replaced but have a problem with electric panel. Sometimes the lights on the Nav Anchor will be on, other times all three of the bilge lights will be on and blinking. Then sometimes the panel won’t even work. I’ve taken it to Bass Pro and they replaced the panel for $400 but it still happens. I’ve tried to contact the Nitro corp office as I am just trying to find someone who can fix the problem. I live on Grand Lake in Oklahoma. Any suggestions of what I may try to check? Repair shop close to me? Someone at Nitro who cares enough to return a call? Appreciate any thoughts. Thanks
 

Larry Williams

Well-Known Member
Joined
Sep 22, 2017
Messages
233
Reaction score
72
Location
Baton Rouge, LA
Bill,

Really sorry to hear about your boat being stolen. That's got to hurt.... I hope you can find someone to help with the issue....
 

beaddy

New Member
Joined
Jun 23, 2020
Messages
3
Reaction score
0
Location
Houston, TX
Bill, did you get this fixed?? I bought a brand new 2019 Nitro Z21 Pro last year and have had this problem since day 1. Tracker has been unable to successfully fix it under warranty and it's been a year now.

I think I've narrowed the issue down to the starboard fuse/wiring panel back by the transom. I'm waiting for Tracker to get one they ordered. Other than that I've had 2 new control panels, one new bow panel and nothing works.

Were you able to get yours fixed?
 

Bill Masterson

New Member
Joined
Mar 27, 2020
Messages
2
Reaction score
1
Location
Grove,Ok
Bill, did you get this fixed?? I bought a brand new 2019 Nitro Z21 Pro last year and have had this problem since day 1. Tracker has been unable to successfully fix it under warranty and it's been a year now.

I think I've narrowed the issue down to the starboard fuse/wiring panel back by the transom. I'm waiting for Tracker to get one they ordered. Other than that I've had 2 new control panels, one new bow panel and nothing works.

Were you able to get yours fixed?
I did but it was a very frustrating experience. Nitro corp was not interested in supporting and the Bass Pro didn't know what they were doing. I finally took it back to the place I bought it in Lawton, ok and the tech there was able to identify it. The issue is that some of the 2019 parts will not work in a 2018 even though they look exactly the same. When replacing items make sure it is the same year part.
 
Joined
Jul 6, 2019
Messages
19
Reaction score
4
Location
Central, Fl.
I did but it was a very frustrating experience. Nitro corp was not interested in supporting and the Bass Pro didn't know what they were doing. I finally took it back to the place I bought it in Lawton, ok and the tech there was able to identify it. The issue is that some of the 2019 parts will not work in a 2018 even though they look exactly the same. When replacing items make sure it is the same year part.
Not related to your experience other than Nitro/Tracker Marine lack of help. They tend to have the attitude that you now own it and it's your problem. I also have had my issues with my 2019 Z20 Pro. Yes it was loaded, the first thing was the 4 primary bolts holding the engine on the jack plate only had a thread or thread and a half on all bolts holding it on. The next issue was dealer related, after coming off the truck they wired my Ultex backwards and I had electrolysis issues on the bottom end of the trolling motor, the anode, all over the jack plate. They rewired it and replace the shaft and lower end of the trolling motor, anode, polished the prop, etc. That problem is solved. I since have purchased a Atlas hydraulic jack plate, the dealer installed only to find all hardware was garbage they had laying around the shop. I replaced all hardware myself with new stainless. I have issues with chine walk at about 70 mph, I have a very keen eye, and standing behind and looking at the engine it appears to be out of plumb with the haul. If I am correct can anyone verify is it possible for this to have happened and how violently will this affect the chine walk??? Thanks Al
 

beaddy

New Member
Joined
Jun 23, 2020
Messages
3
Reaction score
0
Location
Houston, TX
I did but it was a very frustrating experience. Nitro corp was not interested in supporting and the Bass Pro didn't know what they were doing. I finally took it back to the place I bought it in Lawton, ok and the tech there was able to identify it. The issue is that some of the 2019 parts will not work in a 2018 even though they look exactly the same. When replacing items make sure it is the same year part.
Thanks for the info!
 

Latest posts

Top