Quantcast

2nd time to change out 115 trim assembly

Nitro & Tracker Owners

Help Support Nitro & Tracker Owners:

Finman55

New Member
Joined
Mar 23, 2015
Messages
4
Reaction score
0
Location
Oklahoma
I bought new a 2015 V175 Pro Guide Combo. Within the first year the dealer had to change out the trim assembly on the Merc 115. The motor now starts to hang up when I’m trying to bring it back down from trimming it out. The dealer now says the trim assembly needs to be replaced once again on my dime. The part is over $1,100 bucks plus labor. The motor has less than 60 hours on it. Has anyone else experienced with this reoccurring issue?
 

olefisherman456

Active Member
Joined
Sep 5, 2019
Messages
40
Reaction score
16
Location
north east ks.
check the ground connections on the relays . had the same problem, after replacing relays there was no improvement. found that the grounds where the mounting screws attach are a poor design. if I remember I added a small washer where the ground contact was supposed to make contact. no more problem. easy way to check, remove the mounting screw, and use a jumper to make a solid ground. if the trim works have the found the problem.
 

jerry shack

Well-Known Member
Joined
Feb 5, 2013
Messages
136
Reaction score
23
Location
florida
When you mean hangs up does the trim motor still run or does it just stop dead
 

Finman55

New Member
Joined
Mar 23, 2015
Messages
4
Reaction score
0
Location
Oklahoma
It hangs up, the motor is still running though. They also found water in the hydraulic oil. I went ahead & had them replace it but it hit the pocket book hard.
 

jerry shack

Well-Known Member
Joined
Feb 5, 2013
Messages
136
Reaction score
23
Location
florida
Hope you got your old one back. Just in case this is a recurring thing have the old one looked at .
 

Latest posts

Top